本文介绍Windows实例无法启动,通过VNC登录时提示“状态:0xc000000e”错误的问题原因和解决方案。
问题现象
Windows实例无法正常启动,通过VNC登录时提示“状态:0xc000000e”错误。
可能原因
Windows实例系统内存在Xen驱动残留,导致操作系统无法启动。
解决方案
您可以在挂载了修复盘的问题实例中,清理系统中的Xen驱动残留以解决该问题。具体操作如下:
远程连接有问题的实例。
您可以在诊断结果界面单击VNC远程连接,使用诊断报告中提供的临时登录实例的Administrator用户及密码信息登录挂载了修复盘的ECS实例。具体操作,请参见使用VNC登录实例。
根据需要,选择其中一种方式清理Xen驱动残留。
使用Windows PowerShell清理Xen驱动残留
以管理员身份运行Windows PowerShell。
查找已安装的Xen驱动。
假设挂载盘符为D。
$xenDrivers = Get-WindowsDriver -Path D:\ | Where-Object {$_.OriginalFileName -match 'xen'}
卸载已安装的Xen驱动。
$xenDrivers | Remove-WindowsDriver -Path D:\
(可选)安装virtio驱动。
假设virtio驱动目录为
E:\drivers
,执行命令如下:Add-WindowsDriver -Path D:\ -Driver E:\drivers
手动清理Xen驱动残留
在运行对话框中输入
regedit
,单击确定,进入注册表编辑器。选中
HKEY_LOCAL_MACHINE
,然后选择 加载离线注册表,路径为D:\Windows\System32\config\SYSTEM
,注册表名称为OfflineSYSTEM
。删除
HKEY_LOCAL_MACHINE\OfflineSYSTEM\ControlSet001\Services\XenPCI\Parameters
注册表下hide_device
键或者将其值设置为空。
在实例列表页,将鼠标悬浮至修复中的状态上,然后单击卸载修复盘。
重启实例,使以上配置生效。
具体操作,请参见重启实例。
远程连接ECS实例,如果该实例可以正常连接,说明问题已修复。
具体操作,请参见通过密码或密钥认证登录Windows实例。
文档内容是否对您有帮助?